Выделение домена в URL с помощью Excel

Январь 19, 2017

Оставить только домен

=ЕСЛИОШИБКА(ЛЕВСИМВ(RC[-2];НАЙТИ(“.ru”;RC[-2])-1);RC[-2])&”.ru”

Обрезать всё, включая URI и http://

=ЗАМЕНИТЬ(ЛЕВСИМВ(A7;НАЙТИ(“.ru”;A7)-1);1;НАЙТИ(“http://”;A7)+6;)

—–

 

1. In a blank cell which next to your webpage cell, enter the following formula, in this example, I will type the formula in cell B2:=IF(ISNUMBER(FIND(“www.”,A2)),MID(A2,FIND(“www.”,A2)+4,IF(ISNUMBER(FIND(“/”,A2,9)),FIND(“/”,A2,9),LEN(A2)+1)-FIND(“www.”,A2)-4),MID(A2,FIND(“//”,A2)+2,IF(ISNUMBER(FIND(“/”,A2,9)),FIND(“/”,A2,9),LEN(A2)+1)-FIND(“//”,A2)-2)).

 

-0—

1. Hold down the ALT + F11 keys to open the Microsoft Visual Basic for Applications window.

2. Click Insert > Module, and paste the following code in the Module Window.

VBA code: extract domain name from URL

1
2
3
4
5
6
7
8
9
10
Function ExtractDomain(ByVal URL As StringAs String
'Update 20140904
    If InStr(URL, "//"Then
        URL = Mid(URL, InStr(URL, "//") + 2)
    End If
    If Left(URL, 4) Like "[Ww][Ww][Ww0-9]." Then
        URL = Mid(URL, 5)
    End If
    ExtractDomain = Split(URL, "/")(0)
End Function

3. Then save and close the code, go back to the worksheet, and enter this formula =Extractdomain(A2) into a blank cell besides the webpage

 

 

 

—–

 

 

Комментировать